Degraded service due to upstream providers (Cloudflare and Twilio)

Incident Report for Pingdex

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 20:56 EDT

Identified

We are seeing degraded performance when making calls or accessing the Pingdex dashboard due to a regional network issue in the Northern Virginia area.

https://www.cloudflarestatus.com/
https://status.twilio.com/

We will continue to monitor this and update as this incident goes on.
Posted Aug 21, 2025 - 14:47 EDT
This incident affected: Mobile Apps (iOS App, Pingdex Android App) and Pingdex Web Dashboard, Pingdex Voicemail Drop.